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Before you start your roll over check to see you have your data 
correct: 

 

Step 1  Check the Year and Year Following are correct 
Path:  System Functions > Year Level Descriptions 
 
 

Check that your Year Level Codes are set up with the correct Year Following eg. Kindy (KI) students 
become Prep (PR) students or Year 7 students become Year 8 and so on. 
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Step 2  Yet to Come Students 
 
This process checks the accuracy and completeness of data held for any óYet to Comeô students 
through a VDF Query. If you have no óYet to Comeô students entered, you can skip this step. 
 

View Data via VDF Query Report 

Path:  Utilities > VDF Query Generator 
 
Set up and run the following VDF Query to make sure all incoming students information has been 
entered and is correct. 

 
 
Select the SF:Student File as the main file, and add the fields as below. 

 
 

1.  Main File Select SF: Student File 

2.  Fields Tab 

Fields: Highlight then click Add: 

¶ Studkey 

¶ Enrol Status 

¶ Accept Date 

¶ Date Arrival 

¶ Initial Year 

3.  Start (Column) 
Change the Start column to match the VDF example above so it will 
print on an A4 portrait sheet of paper. 
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Then go to the [Selection Tab]     

 
Double Click a Field to Add: 

1.  Fields 

Current Year: 

¶ Select Equal to [=] ï click OK 
Date Arrival: 

¶ Select Between [x-y] 

2.  Selections The Fields must be visible. 

3.  Default Value 

Enter the Current Year as a - Space Zero  e.g. [ 0] 
Enter Date arrival to cover the date you have entered in Students 
View > Enrolment > Date Arrival, this must cover the start date of the 
new Students. 

4.  Run Click Run to print the Report. 

 
Enrol status 

¶ Australian Schools should be óAcceptedô 

¶ New Zealand Schools will be óRegularô Student in most cases 
All columns must have Data; those without data or with incorrect data in the columns must be 
corrected. 
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Correct the data 

Path:  Administration > Student View > Enrolment Tab 
 
Correct the missing information: 

¶ óDate Arrivalô is very important, as it is the main factor when rolling in new students 

¶ Initial Year: this must be entered for ñYet to Come Studentsò 

¶ Optional: Enrolment Status, if used by your school, must be correct, so they are placed 
correctly. 
 

 
 

To correct the Students Details follow the instructions below: 

¶  In Restrict by Year, select Yet to Come. 

¶  Enter the correct information for the Students in the Enrolment Tab. 

¶  Click Save for each Student after the details have been corrected. 
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Step 3  Current Students Repeating a Year 
 
This must be done prior to rolling Students into their Next Year Level. If you have no current students 
repeating this year, you can skip this step. 
 
Path:  Student View > Tab 4 Enrolment 
 
This is for students who will not be progressing on to the following year level but will be remaining in 
their current year level. 

 
 

For Students Repeating the year level they are now in; 

¶  The only thing that needs to be done is to place a Tick in óRepeating Next Yearô. 

¶  
After the rollover this will move to óRepeating This Yearô and the year level being repeated 
(eg. Yr 8) will show in the óYears Repeatedô field. 

¶  Click Save. 

 
  



 

 

Version 201812  7/26 

 

Step 4  Students not Returning Next Year 
 
This step can be ignored if you do not have students leaving next year other than students in their final 
year level. 
 
This is for students who will be departing prior to your final year; 

¶ This is not for students who are in the final school year 

¶ Students in their final school year are automatically departed 
 
 
Path:  Administration > Student View > Tab 4 Enrolment 
 
This must be done prior to rolling students into their óNext Year Levelô. 

 
 

For Students not returning next year; 
 

¶  
There is no need to put in a departure date or final year as this information will be 
automatically generated when rolling students. 

¶  Check óExclude Next Yearô. 

¶  Click Save. 
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Step 5  Mailing Title for the Alumni 
 
Path:  Utilities > System File maintenance > Settings 
 
Prior to rolling Students into the Alumni, you can select the mailing title defaults that will go with them. 
The default, unless selected, is the format Miss or Mr M J Smith (Given Initial). 
 
 

 
 

  



 

 

Version 201812  9/26 

 

Step 6  Enhanced Alumni Email Option for Student Rollover Process 
 
With a growing number of schools offering students a ñlife-timeò email address, this can now be 
carried through into their Alumni file instead of the current process of using the caregiverôs email 
address. 
 

 
 
When transferring departed students to Alumni, choose which email address you require. 
Ensure this setting has been made prior to the ñEnd Of Yearò rollover process. 
 

1.  
Correspondent Email ï this is who has been selected for the ñContact (Email) Option:ò 
under the correspondence tab Student View > Address tab > Correspondence tab 

2.  
Student Email ï this is the studentôs email that appears under the Student View > Scholastic 
tab > Email 

3.  
Both ï this will select both the ñCorrespondentôs and the Studentôs Email. 
This will be included and separated by a semicolon. In the case of extremely long email 
addresses, one of the correspondence email addresses may be omitted. 
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ROLLOVER PROCEDURES: Important steps to check 
before Rolling over 

The following steps need to be done before proceeding. 
Make sure that these are done as PCSchool may not be 
able to recover data in case of an issue during roll over 
process. 
 

 

Step 7  Ask your IT to do backups etc as per the manual  
End of Year Backup Information for IT 
 
 

Step 8  Check that the computer performing the rollover 

Has the correct licence files installed on the computer 
 
On the computer being used for completing the PCSchool rollover, check if it has the Version 14 
licence files. These are generally found on the local C: drive C:\Program Files x86\Visual DataFlex 
11.0\Bin folder. 
 

1. Locate the file sql_drv.dll, 
2. Right click on file and select [Properties]  
3. Select the [Details Tab] - . it must read Version 14.??? (as per screen shot below) 

 
 

If you do not have the correct version, DO NOT PROCEED ï contact your 
IT Staff or call PCSchool to obtain your current sql_drv.cfg file and 
updated sql_drv.dll file. 
  

http://www.pcschool.net/wp-content/pcschool-uploads/endofyear/eoybackup.pdf
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Step 9  SQL backup just before rolling 
Path:  Scholastics> Utilities > Work Area Maintenance 

 
1. Make sure you have select the correct work area to backup.   
2.[Backup SQL Database]  
 
Popup: 

 
Add at the end of the word Backup ï e.g. EOY b4 Curr Roll and the date  - OK 
 

 
1. You will get a message saying [Backing up PCSchool]. Do not do anything yet wait until you get a 
message   [Done Backup Successful]   
2. When you get this message select ï[close] ï it has now created your SQL Backup  
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Step 10  Make sure you are on the correct version 

For, please ensure your version is at least 2018.0.0.220 or higher 
Path:  Scholastic> Help> About 
 

 
 

If not, download the latest followup from our website 
http://www.pcschool.net/support/updates-downloads/ 
 

Step Note:  We strongly recommend that you use the ófastestô PC 
available, the server generally being the ideal choice.  
 

Step 11  Do a Full Backup within PCSchool 
Path:  Utilities > Backup 

 

 
1.  Select ï All Files 

2.  Select All 

3.  Backup Data 

http://www.pcschool.net/support/updates-downloads/
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This process may take some time and once itôs completed, it will show the below screen asking 
where to copy the backup to.  

 

1.  

Destination ï (By default itôs copied to the ñBackupò folder inside the local 
ñPCSLaunch\Backupò folder.)  
This can be changed ï you could save it to desktop then transfer, or save it to your 
PCSchool Server 

2.  
File Name ï (The backup files are zipped and has the time stamp on the file name)  

¶ Change name to ñEOY Full Back  (if backing up another workarea - type the work 
areas name) as per example 

3.  Select ï [Create Backup] 

 

It is critical that you check that this file has been created.  
The logged in user must have permission to write to the default location, or this needs to be changed 
prior to pressing the ñCreate Backupò button.  

¶ After completion, ALWAYS browse to the location to check that the file is present 

¶ Open the file so you can see all the files ï if not, DO NOT PROCEED ï contact PCSchool 
 

 
 

This process must be repeated on different work areas before they are rolled over. 
 

Step 12  Ensure everyone is logged out of PCS 

Ensure no one is logged on to PCSchool prior to running the End of Year 
Rollover as this module is integrated with both the Debtors and General 

Ledger modules 
 

You can lock all users out of PCSchool while you are doing End of Year ï see attached link ï just 
make sure you unlock when you have finished. 
 

http://www.pcschool.net/wp-content/pcschool-uploads/tools_sysadmin/lockingusersoutofpcschool.pdf 

http://www.pcschool.net/wp-content/pcschool-uploads/tools_sysadmin/lockingusersoutofpcschool.pdf
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Step 13  First step is to create your Snapshot (which is a copy of your 
database) 
Path:  Scholastic> Administration> Year-End Housekeeping 
 
Create a Snapshot 

The first step of this procedure will create a snap shot of your Scholastic data this allows you to recreate 
reports based on enrolments and absences for the previous year. 

1.  Check that the correct year level has the next year of 99 and it has a tick in Depart column. 

2.  Tick, [Update Student Year Levels]. 

3.  

Optional: [Update Student Form Class with Form Class Next] and [Update Student 
Core Class with Core Class Next]; 

¶ Only tick if you have entered students new Form Class or Core Class into the 
relevant field of Form Class Next and/or Core Class Next in Student View/ Enrolment 
Tab. 

4.  Optional: [Transfer Departed Students to Alumni:] 
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¶ This will only copy the students to the Alumni area but they will still remain in your 
main data until removed through Student - Family Removal (see Debtors End of 
Year Manual for more information). 

5.  
Optional: [Create Alumni from Family record]; 

¶ This will create new records in your Alumni file based on Family records. 

6.  Select the [Departure Date] This is generally the date of the last day of school. 

7.  Tick; [Roll in Yet to Come Students]. 

8.  
[Arrival Date From:] Select a suitable date that will include all arrivals for beginning of the 
following Year. 

9.  [Arrival Date To] select a this must cover the arrival date of the following Year. 

10.  

Select the [Acceptance Date From] 

¶ This may need to be 4 or 5 years prior to cover all Acceptance dates. If no 
acceptance dates are entered in Student View remove this date as only those with 
dates will be rolled in. 

11.  
Select the [Acceptance Status your school uses] 

¶ This is the Enrolment Status and is important if you have students on waiting lists. 

12.  Click [Begin Process] to create the snap shot. 

 

Step 14 Pop up box 
If ticked, you will be asked if you wish to send Families of Past Students to the Alumni.  
 
This is a decision that only the schools can make. 
 

 
 

 



 

 

Version 201812  16/26 

Step 15 
You will then be asked the Format you wish the Alumni Mailing Title to be in, this will show the default.  
 

¶ In Step 5 you should have already done this, so select  YES 

¶ Select NO  - to edit .     Path:    Utilities > System File maintenance 
 

 
The next screen will pop up ï  
 
You should have amended this in Step 6  -  
 

 
 

¶ To change this select -  N 

¶ To carry on select - Y  
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Step 16  
A pop up screen will appear ï select YES to create your Snap Shot (this may take some time) 
 

 
 
Wait ï a pop-up box will appear ï select OK 
 

 
 

Wait ï a pop-up box will appear ï select OK 
 

 
 

Wait ï a popup box will appear ï select OK 

 
 
The system will now copy over Tables ï wait until popup box  
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Step 17  Popup screen  

 
This has created a snapshot called - Curr Data 2018 
Select ï OK 
The program will exit out of PCSchool when finished 
 
Note:  This has not rolled over the students ï it has only made a copy of your database 
 

 

Step 18  IMPORTANT ï check snapshot 
 

a. Log back into PCSchool under the snap shot created e.g. Curr data 2018    
b. Check the data i.e. Students are still in this same year levels for the current year  
c. Select a student under Student View ï and under the address tab place an X after the address 

as e.g. 

d.  
 
 

For FREEDOM SCHOOLS ï (suggest changing a Staff members address by putting a óxô 

after the address or changing a studentôs class in Subject view, check the mainwork area ï if you see 
this óxô ring PCSchool helpdesk, we suggest you change back in the snapshot after). 

 
 

LOGOUT 
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Step 19  Log back into the Mainwork area 
 
Log back into PCSchool under the Mainwork area > Scholastics.  
 

IMPORTANT:  Call up the Student that you used in Step 18(c) and check 
the address tab and make sure the x is not showing ï if it is, you need to 
call the PCSchool helpline , if not showing continueé 
 
Now to repeat the process and actual roll the students in to the new year. 
 
Path:  Scholastic >Administration > Year-End Housekeeping 
 
Reselect all the settings once more. (see Step 19 for details) 
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Step 20 
You will be asked if you wish to send Families of Past Students to the Alumni (do what you previously 
decided) note this is a decision that only the schools can make. 
 

 
 

Step 21 
As previous - you will then be asked the Format you wish the Alumni Mailing Title to be in, this will 
show the default. Select  YES 
 
 

 
Popup screen ï select Yes 
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Step 22 

A popup screen will appear ï select [NO] as you have already created the snap shot (note: this 

now may take some time to process) 

 
 

Step 23 
Pop up screen ï Select YES 
 

 
 

Step 24 
Waitéonce the rollover has completed, check that your students are in the correct yearsô year levels 
for next year. 
 
  


